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Les pages suivantes vous présentent la suite de logiciels OrCAD 17.2 
Lite. 

 

Ce guide a été élaboré dans le but d’évaluer rapidement ces outils de 
conception de circuits imprimés et de simulation fonctionnelle. 

 

Cette version de démonstration inclut la totalité des commandes 
d’OrCAD PCB Editor mais vous ne pourrez sauvegarder qu’une carte 
comportant 100 équipotentielles et/ou comportant 50 composants 
maximum. 

 

Ce guide montre comment générer, à partir d’un schéma saisit dans 
Capture CIS, la netlist d’un circuit et comment la charger dans PCB 
Editor.Il donne par la suite les explications pour effectuer un placement 
simple et un routage manuel. 

 

La dernière partie du livret vous permettra de prendre en main PSpice. 

 

 

 
Les fichiers d’exemples pour suivre le guide sont disponibles à cette 
adresse http://www.artedas.com/FR/OrCAD/OrCAD_Lite.php 
 

 

 
 

  

Introduction 

http://www.artedas.com/FR/OrCAD/OrCAD_Lite.php
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Système minimum requis:  

 

- Windows 7 (64 bits) version Familial Premium, Professionnel, 
Entreprise et Ultimate, Windows 8 (64 bits), Windows 8.1 (64 
bits),Windows 10 (64 bits) Windows Server 2008 R2 (64 bits) et 
Windows Server 2012 (64 bits). 
 
-Architecture recommandée : Processeur Intel Core 2 Duo 2.66 GHz ou 
AMD Athlon 64 X2 5200+ (processeurs très rapides conseillés) ; 8 GB de 
RAM; mémoire virtuelle au minimum deux fois supérieure à la RAM ; 
500GB d’espace disque ; carte graphique (Gestion de l’OpenGL), 
résolution 1280x1024 couleur 32 bits. 
  
Windows XP, Windows Vista et Windows 7 (32bits) Home Basic et 
Starter ne sont pas supportés. 
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L’installation peut se faire en tant qu’utilisateur standard ou en tant 
qu’adminsistrateur. En tant qu’adminsistrateur, le logiciel pourra être 
accessible à tous les utilisateurs. 

 

 Dézippez le fichier téléchargé. Lancez l’exécutable 17.2-2016-
OrCAD-PSpice-Designer-Lite ou l’exécutable setup  du dossier 17.2-
2016-OrCAD-PCB-Designer-Lite selon le ficher compressé que vous 
avez téléchargé. 

 Cliquez sur  pour lancer l’installation. 

 Acceptez les termes de la licence en cochant la case 

correspondante puis cliquez sur le bouton . 

Dans la fenêtre Setup Type, si vous êtes connecté en tant 
qu’administrateur et si vous souhaitez que le logiciel soit accessible à 
tous les utilisateurs, sélectionnez cette option : 

 

 

 . 

La fenêtre suivante Choose Destination Location permet de choisir le 
chemin de l’installation. Vous pouvez le modifier en cliquant sur le 
bouton Browse. 

 . 

 La fenêtre Installation Summary apparait.  

 . 

La fenêtre Setup Complete apparaît : 
 

 Vous pouvez sélectionner l’option View Product Notes pour 
obtenir des informations sur la version installée sinon cliquez sur 

. Ne sélectionnez pas l’option Remove Cadence 

Installation de la 

version Lite 
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paths… si vous avez des versions antérieures (v16.x ou v15.7) 
installées. 

 

ATTENTION : Si l’installation a été faîte en tant qu’utilisateur 
standard, il est toutefois nécessaire pour avoir accès à toutes les 
fonctions du logiciel, notamment les bases de données, de lancer 
l’exécutable InstallConfig.exe (répertoire 
C:\Cadence\SPB17_2\Tools\InstallUtils) avec les droits 
d’administration. Une fois lancé, sélectionnez l’option Perform one 
time system level Configuration. 
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Créer un projet : 

 Copiez au préalable le fichier DemoBENCH.db contenu dans le 
fichier compressé que vous avez téléchargé dans le répertoire 
…Cadence\SPB_17.2\tools\capture\samples 

 Lancez le programme OrCAD Capture CIS à partir du menu 
Démarrer→Cadence Release 17.2-2016 →OrCAD Products. 

 

La fenêtre de Capture apparait. 

 

Patientez quelques instants pour que la fenêtre soit active. En effet le 
premier lancement peut prendre un peu de temps. 

 

 Agrandissez la fenêtre.  

 Allez dans le menu 
File→New Project de Capture 
CIS, cette fenêtre apparait :  

 

 Complétez-la comme indiqué 
: 

Nom du projet : Demo1 

Location : C:\SPB_Data  

…puis cliquez sur le bouton OK. 

 

La fenêtre de Capture CIS va maintenant comporter une fenêtre 
Project Manager et une page schéma vierge (SCHEMATIC1 :PAGE1). 

Utilisation d'OrCAD 

Capture CIS 
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Placer des composants avec CIS Explorer : 

Pour faciliter la saisie du schéma et notamment l’utilisation de 
propriétés spécifiques, nous vous proposons d’utiliser la base de 
données de composants Bench.DB fournie avec le fichier exemple. 

 

 Cliquez sur la page schéma avec le curseur de souris (pour la rendre 
active) puis appuyez sur la touche Z du clavier ou allez dans le menu 
Place→Database Part.  

La fenêtre ci-après devrait s’afficher : (elle peut être agrandie en l’étirant 
par un des coins) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Cliquez sur le signe « + » à gauche du nom BenchAccess172D 
puis faites de même sur tous les signes « + ».  

La fenêtre Explore devrait ressembler à ceci : 

 Sélectionnez la famille CMOS Logic. 

Une seule ligne de composant apparait dans la fenêtre du bas. 

 Cliquez sur la ligne. 

Ses représentations graphiques schéma et pcb apparaissent dans les 
fenêtres correspondantes ainsi qu’une fenêtre de la représentation 
« Footprint » (sélectionnez préalablement le menu 
View/Toolbar/Footprint Viewer ). 

 Double-cliquez sur la ligne du composant pour le placer sur la page 
schéma. 
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Réalisation du schéma 

Seul le symbole graphique de J1 sur cette image est placé directement 
à partir de la bibliothèque Connector.olb de Capture. 
(..\tools\Capture\Library…) tous les autres composants seront placés à 
partir de CIS Explorer. 

 

 Allez dans le menu Place→Part, ou 

cliquez sur l’icône  . 

 Cliquez sur cet icône pour ajouter des 
librairies. 

 Sélectionnez le fichier connector.olb dans 
le répertoire 
C:\Cadence\SPB_17.2\tools\Capture\library\ 
puis Ouvrir. 

 

 

 Pour poser le composant sur la 
page schéma: 

 

 

 

 

 Tapez con6 dans le champ Part puis touche 
Entrée puis cliquez avec le bouton de gauche pour le poser sur la page 
schéma. 

(L’élément reste sur le pointeur de la souris jusqu’à ce que vous 
appuyez sur ESC ou sélectionnez  End Mode après un clic sur le 
bouton droit de la souris). 

Tapez con6 ici… 
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Placer des symboles d’alimentations : 

 Cliquez sur l’icône  ou allez dans le 
menu Place→Power. 

 Choisissez le symbole GND puis cliquez 
sur OK pour le placer sur le schéma.  

Ce symbole est déplaçable, copiable à 
volonté. Si vous souhaitez le déplacer alors 
qu’il est connecté, alors vous appuierez sur la 
touche Alt avant de le déplacer pour qu’il se déconnecte simplement. 

Réaliser des connexions : 

 Sélectionnez la commande Wire dans le menu Place (ou W)  ou 

. 

Puis créez les connexions. (Cliquez sur le bouton gauche, déplacez la 
souris, cliquez sur le bouton gauche). 

 Appuyez sur ECHAP ou W pour sortir du mode Wire. 

D’une broche à une autre, le curseur de souris est libéré 
automatiquement, soit vous souhaitez interrompre une connexion à un 
endroit de la page schéma il suffit de double-cliquer avec le bouton de 
gauche ou appuyer sur la touche Echap. 

Placer des alias de net : 

 Sélectionnez la commande Net Alias dans le menu 

Place (ou N) ou . 

 

 Tapez « Buz+ ». 

 Placez le cadre inférieur du Net Alias  sur le fil, puis cliquez sur le 
bouton gauche de la souris, placez le deuxième alias qui va matérialiser 
la connexion entre les deux points comme sur le schéma de la page 9. 

Propriétés d’un symbole : 

 Double-cliquez sur le symbole Conn6, la fenêtre de propriétés 
s’ouvre, celles-ci sont toutes alignées. Cliquez avec le bouton de droite 
dans la case complètement à gauche dans le tableau et choisissez la 
commande Pivot. 
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 Dans la nouvelle présentation du tableau, localisez la propriété PCB 
Footprint et tapez-y la valeur Conn6.  Fermez la fenêtre. 

 Sélectionnez le symbole Conn6 puis clic-droit→Show Footprint.  

 

Fonctions Mirror, Rotation,…  : 

Sélectionnez le symbole graphique Conn6. 

Appuyez sur la commande Mirror 
Vertically en cliquant  sur  le bouton droit de 
la souris.  

Faites de même sur tous les 
éléments (composants, fils ect …) 
qui le nécessitent pour obtenir un 
schéma semblable à celui de la 
page 9. Les composants se 
placent à partir de la base CIS 
(touche Z). 
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Annotation du schéma : 

Lors du placement des 
symboles, les références 
sont incrémentées 
automatiquement car l’option 
Automatically reference 
place parts est active par 
défaut. (Menu 
Options→Preferences→on
glet Miscellaneous). 

Néanmoins, si ça n’est pas le 
cas : 

 Sélectionnez le fichier 
demo1.dsn dans le Project 
Manager puis allez dans la 
commande 
Tools→Annotate. 

 Cochez l’option 
Unconditionnal Reference Update puis cliquez sur le bouton OK.  

Toutes les références sont ré-annotées. 

 

Création de la netlist pour 
PCB Editor : 

 Cliquez sur le bouton  afin 
de revenir dans la fenêtre de 
gestion du projet. 

 Sélectionnez le fichier 
demo1.dsn dans le dossier 
Design Resources. 

 Sélectionnez la commande 
Create Netlist à partir du menu 
Tools.  

 Sélectionnez le feuillet PCB 
Editor. 

 Assurez-vous que le nom allegro apparaisse dans le champ Netlist 
Files Directory. 
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 Cliquez sur le bouton OK, un message concernant la création d’un 
répertoire allegro va apparaitre, cliquez sur OK. 

Un autre apparaitra pour valider la sauvegarde du fichier de schéma 
avant la création de la netlist. Cliquez sur le bouton OK. 

 

 

Trois fichiers portant l’extension *.dat ont été créés dans le répertoire 
allegro de OrCAD_Data.  

Ces trois fichiers représentent ce que l’on appelle habituellement la 
netlist. 

Tous les fichiers servant à l’évaluation sont fournis dans le dossier PCB 
Editor du fichier compressé que vous avez téléchargé. 
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Importation de la netlist :  

 Lancez PCB Editor à partir du menu 
Démarrer→Cadence Release 17.2-
2016 →OrCAD Products pour les 
systèmes W7.  

 Menu File→Open et ouvrez le 
fichier Demo.brd fournit avec les 
fichiers Exemples puis sauvegardez-le 
File→Save As File sous le nom 
Demo1.brd dans le repertoire 
C:\SPB_Data\allegro 

 Allez dans le menu Import→Netlist, la fenêtre suivante apparait : 

 Sélectionnez l’option Design entry CIS (Capture). 

 Vérifiez que le chemin en bas de la fenêtre pointe bien vers le 
répertoire allegro du projet Capture ou laissez le « . » puis cliquez sur le 
bouton Import Cadence. 

 Sauvez le fichier de la carte File→Save. 

Placement manuel des 
composants : 

Les composants sont intégrés maintenant au 
fichier de carte et sont disponibles par la 
commande du menu Place→Components Manually. 

Utilisation d'OrCAD 

PCB Editor 
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 Allez dans le menu Display→Zoom→Fit. 

 Allez dans le menu Place→Components Manually et sélectionnez 
la coche en face du nom C1 puis cliquez sur le bouton Hide de la 
fenêtre, celle-ci disparait.  

Le composant est accroché au curseur de la souris.  

Le niveau de zoom est peut-être insuffisant : 

 Cliquez avec le bouton du milieu de la souris et dessinez un 
rectangle en remontant vers la gauche et validez-le en cliquant avec le 
bouton de gauche. L’affichage s’agrandit et le composant est toujours 
accroché au curseur. 

Faire pivoter un composant 
 Cliquez avec le bouton de droite de la souris (le 
composant est toujours accroché au curseur), le 
menu contextuel apparait. Choisissez la 
commande Rotate.  

A partir de cet instant un vecteur est apparu entre 
le curseur et l’origine du composant. 

C’est ce vecteur qui va permettre de faire pivoter 
le composant. 

Les options du panneau de contrôle permettent de 
modifier l’incrément de l’angle avec lequel l’objet 
peut pivoter. 

 Tourner autour du composant, celui-ci suivra. Une fois la rotation 
désirée obtenue, cliquez sur le bouton de gauche pour poser le 
composant à l’endroit voulu. 

La commande Place 
Manual est toujours active. 

 Faites un clic-
droit→Done pour en sortir. 

Autre solution : Faites appel au fonctionnement 
sensitif et contextuel en cliquant directement avec le bouton de gauche 
de la souris sur le composant à bouger et sans le relâcher, utilisez le 
clic-droit de la souris pour appeler la 
commande Rotate. 

Changer un composant de face: 
 Cliquez sur le composant C1 puis appuyez 
sur le bouton de droite de la souris et 
choisissez la commande Mirror. 

Le composant est changé de face.  

 Cliquez sur le bouton de gauche pour 
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validez la position du composant. 

La commande Place Manual est toujours active. 

 Cliquez avec le bouton de droite de la souris et choisissez la 
commande Show. 

La fenêtre de placement manuel réapparait, le composant C1 placé a 
disparu de la fenêtre de placement. 

 Placez le reste des composants sur la carte avec les commandes 
découvertes précédemment. 

 
Figer ou non un composant : 

 Cliquez sur l’icône  puis ajuster l’onglet 
Find du panneau de contrôle en ne sélectionnant 
que  Components.  

 Cliquez sur le composant qui doit être fixé à un 
emplacement donné. 

La propriété FIXED est injectée sur ce composant. 

Le même procédé est à utiliser pour dé-fixer un composant en cliquant 

sur l’icône . 
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Changer la grille de placement : 
 Allez dans le menu Setup→Grids. La fenêtre suivante vous permet 
de changer la grille de type Non-Ecth (Placement) et la grille Etch 
(Routage et tout ce qui dessiné sur une couche…). 

 

 

 

 

 

 

 

 

 

 

 

Placer un texte sur une couche : 

 Allez dans le menu Add→Text puis choisissez 
le bloc de texte 2 à placer sur la couche TOP.  

 Cliquez à l’endroit de la carte où placer un 
texte, puis tapez CARTE DE DEMO. 

 Cliquez avec le bouton de droite puis 
choisissez la commande Done. 

Le texte apparait avec un tracé très fin (en fait 1 
pixel). Il faut donc en changer 
la largeur. 

 Allez dans Setup→ 
Design Parameters, oglet 
Text puis cliquez sur le 
bouton Setup Text Sizes et 
remplissez la largeur comme 
indiqué : 

 Cliquez sur le bouton OK. La fenêtre se ferme en appliquant le 
changement. 
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Informations sur des éléments : 

 Allez dans le menu Check→Element ou cliquez sur l’icône   . 

L’onglet Find du panneau de contrôle permet de sélectionner le type 
d’éléments sur lequel des informations doivent être recherchées. 

 Ne changez rien sur le réglage du panneau et cliquez avec le 
curseur sur le trait le plus à l’extérieur de la carte (Le contour en fait…). 

Une fenêtre s’ouvre affichant le type de données sélectionnée. 

 Allez dans le menu File de cette fenêtre et choisissez la commande 
Stick (Celle-ci « colle » le rapport dans l’interface de PCB Editor). 

 Cliquez de nouveau avec le curseur de souris sur le rectangle (en 
violet)  immédiatement à l’intérieur du contour. 

Un autre rapport est affiché, collez-le aussi avec la commande Stick. 

Les deux fenêtres sont affichées dans l’environnement graphique de 
PCB Editor. 

 

 

 

 

 

 

 

 Placez le curseur de souris sur la fenêtre de travail puis appuyez 
avec le bouton de droite de la souris et choisissez la commande Done. 

Les deux fenêtres sont toujours affichées et les coordonnées affichées 
sont dynamiques avec les coordonnées du fichier de carte. 

 

 Cliquez sur l’une des coordonnées, l’affichage est recentré sur cette 
coordonnée. 
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Zooms dynamiques : 

 Appuyez sur le bouton central de la souris dans la fenêtre de travail 
puis dessinez un rectangle en partant vers le haut à gauche puis 
validez-le avec le bouton gauche de la souris. L'affichage s'agrandit. 

 Appuyez sur le bouton central de la souris dans la fenêtre de travail 
puis dessinez un rectangle en partant vers le bas à droite puis validez-le 
avec le bouton gauche de la souris. 

La taille de l’affichage est diminuée. 

 Appuyez sur le bouton central de la souris ET gardez le bouton 
appuyé puis déplacez le curseur…l’affichage se déplace avec les 
mouvements de la souris. 

 Appuyez sur la touche F2. La carte est affichée en totalité. 

 Faites rouler la molette en avant puis en arrière, l’affichage est 
agrandit ou diminué. 

Le chevelu des équipotentielles : 

Le chevelu peut-être rendu invisible en cliquant sur l’icône  ou 

visible en cliquant sur l’icône . 

De plus les menus Display→Show Rats ou Blank Rats permettent de 
filtrer l’affichage en fonction de nets ou de composants. 

Routage manuel : 

Réglages des 
contraintes par défaut : 
 Allez dans le menu 
Setup→Constraints, le 
Constraints Manager 
s’ouvre puis cliquez sur le dossier Physical.  

Cette fenêtre indique les 
paramètres qui 
déterminent la largeur de 
conducteur en dessous 
de laquelle le concepteur 
ne pourra descendre. 

 Cliquez sur le dossier Spacing, dévoilant ainsi les isolations utilisées 
par défaut.  
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Réglages des contraintes étendues : 
 Cliquez sur le 
tableau All Layers de 
la partie Net Class- 
Class et affectez les 
jeux de contraintes 
comme indiqué.  

L’interprétation en est 
très simple : lorsqu’un objet de type non-défini rencontrera un objet du 
type ALIM alors PCB Editor devra utiliser une isolation définie par le jeu 
Space_0.3. 

D’autres jeux peuvent être définis avec le clic-droit de la souris en 
choisissant la commande Create→Spacing Cset. 

 Cliquez sur le bouton Cancel. 

 

 Cliquez sur le dossier Nets de la 
partie Physical puis affectez les jeux 
de contraintes comme indiqué.  

Dans ce cas, lorsqu’un objet de type 
ALIM devra être routé, PCB Editor 
utilisera une largeur de piste de 
0.3mm. 

 File→Close pour fermer la fenêtre du Constraint Manager. 

 

Tracer des pistes : 
 Allez dans le menu Route→Connect ou cliquez 

sur l’icône  . 

Le panneau de contrôle change d’allure et permet 
d’accéder à des options pour le routage interactif. 

La paire de couches de routage est définie dans le 
haut de cette fenêtre, la ou les vias ne seront 
accessibles qu’à partir du moment où une 
équipotentielle sera sélectionnée pour le routage  

 Cliquez sur la broche la plus à gauche du 
connecteur J1 puis décalez le curseur vers le bas 
en vous orientant vers le point de destination. 

 Ne vous approchez pas trop prés de la pastille 
de destination afin d’éviter que l’outil ne connecte tout de suite la piste 
puis cliquez avec le bouton de gauche à l’endroit ou le curseur se 
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trouve. La portion de piste est posée sur la carte et le chevelu 
réactualisé. 

Vous remarquerez que le routage s’effectue par portion composée de 
deux segments. 

 Bouger le curseur de souris de sorte à traverser des zones 
comportant d’autres pastilles. La piste évite les objets qu’elle rencontre. 
Finalisez le routage sur la pastille de destination. 

 Cliquez sur la deuxième pastille la plus à gauche du connecteur puis 
tracez une portion de piste jusqu’à arriver à deux-trois millimètres de la 
piste précédemment tracée puis double-cliquez à l’endroit où se trouve 
le curseur, une via est posée à cet endroit et le routage change de face. 
Passez en dessous de la première piste puis replacez une via pour 
finaliser le routage. 

 Cliquez sur la broche 7 de U1, la piste qui va être tracée est plus 
large (Jeu de contrainte Larg_0.3). 

 

Les pistes en cours de routage peuvent pousser des éléments tels que 
des traversées ou des pistes si le paramètre Bubble est réglé sur 
Shove Preferred. Si ce paramètre est réglé sur Hug Only ou Hug 
Prefered alors la piste de routage évitera les autres traversées et 
pistes. 

Il est possible de revenir en arrière soit en retraçant sur la piste en cours 
de routage une nouvelle piste qui disparaitra ou alors en utilisant la 
commande Oops du menu du bouton de droite de la souris dans la 
commande. 

Autre Solution : Le routage peut être fait directement à partir d’une 
pastille ou d’un chevelu sans lancer préalablement la commande Add 
Connect. Il suffit que le mode d’application (Clic droit Application Mode) 
soit réglé sur Etch Edit et de cliquer directement sur un élément 
routable (attention aux éléments sélectionnés dans le panneau Find). 

 

Supprimer un routage : 
La suppression de pistes et de traversées peut être filtrée sur l’objet 
Net. 

 Allez dans le menu Edit→Delete ou cliquez sur l’icône  . 
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 Cliquez sur l’onglet Find du panneau de contrôles et ne cochez que 
Clines et Vias. 

 Cliquez sur une piste, elle est sélectionnée, puis cliquez une 
deuxième fois ou choisissez la commande Done du menu contextuel. 

La piste est supprimée. 

 Si vous avez choisie la commande Done, alors recliquez sur l’icône 
Delete. 

 Dessinez une fenêtre de sélection avec le bouton de gauche de la 
souris puis validez votre sélection avec la commande Done. 

Les pistes et traversées sélectionnées sont supprimées. 

 Retournez dans la commande Delete puis dans l’onglet Find, ne 
sélectionnez que Nets et cliquez sur l’onglet Options et n’y cochez que 
Clines. 

 Choisissez la commande Temp Group dans le menu du clic-droit 
puis cliquez sur plusieurs pistes en différents endroits de la carte et 
choisissez la commande Complete. 

Les pistes sont sélectionnées. 

 Validez la suppression en cliquant n’importe où 
sur la carte avec le bouton de gauche. 

Les pistes et seulement les pistes sont supprimées. 

Autre Solution : Placer le curseur au dessus d’une 
piste puis avec le clic-droit de la souris, choisissez, 
soit la commande Delete, soit la commande 
Net→RipUp Etch. 

Dessiner des zones de cuivres : 
Les zones de cuivres attachées à une 
équipotentielle peuvent être dynamiques et ainsi 
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être mises à jour automatiquement dès qu’un élément constitué de 
cuivre y est placé.  

 Allez dans le menu Shape→Polygon ou cliquez sur l’icône  et 
réglez   l’onglet des options comme indiqué par l’image ci-contre : 

 Dessinez une zone (connectée à 9V) sur la carte qui englobe le 
connecteur et le dip14.  

La zone sera remplie dés 
que vous aurez cliqué sur 
le point de départ ou dés 
l’utilisation de la 
commande Done du menu 
contextuel. 

Il est possible d’assigner 
une équipotentielle en 
utilisant la commande 
Assign Net du menu 
contextuel. 

 

Le remplissage réel peut être 
changé en utilisant la 
commande du menu 
Shape→Select Shape or 

Void ou avec l’icône . 

 Cliquez sur la zone de 
cuivre avec la commande 
Select Shape active. 

Cette zone est sélectionnée et 
chaque extrémité de segment 
est matérialisée par un petit 
carré qui peut être utilisé pour 
changer la forme de la zone. 

 Le menu contextuel vous 
permet d’accéder à la 
commande Parameters. 

 

Une fenêtre est affichée : 

 Choisissez Xhatch pour le paramètre Fill Style puis réglez les 
suivants sur l’exemple de l’image : 
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Après avoir cliqué sur le bouton OK ou Apply, la zone de cuivre 
(shape) est mise à jour. 

Vous devriez obtenir un remplissage quadrillé à 45°. 

 Allez dans le menu Route→Connect puis cliquez sur une pastille 
puis routez (ou –re-routez) une piste dans le shape… 

La piste créée un passage dans le shape qui est remis à jour 
immédiatement. 

 Utilisez la commande Edit→Mirror puis cliquez sur un élément de 
type CMS pour le faire passer de la face TOP à BOTTOM puis de 
BOTTOM à TOP. 

 

 

 

 

 

 

 

 

 

Le shape est mis à jour en isolant les pastilles du composant. 

 Sauvez le fichier en utilisant la combinaison de touches Ctrl+s.Vous 
pouvez continuer avec votre fichier BRD ou ouvrir le fichier exemple 
demo_routed.brd. 

Créer des rapports : 
Une grande variété de rapport peut être créée avec la commande du 
menu Export→Quick Reports. 

 Choisissez le rapport Component Report dans la liste. 

 

 

 

 

 

 

 

Création du tableau et plan de perçage : 
Pour créer le tableau de perçage il faut que les sous-classes TOP, 
BOTTOM soient rendues visibles. 
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 Utilisez la commande à partir du menu Manufacture→Customize 
Drill Table. 

Cette fenêtre vous permettra de changer des informations de perçage 
avant de générer le tableau de perçage. 

 Sortez de cette fenêtre en cliquant sur le bouton OK puis en validant 
la mise à jour de la carte avec les informations éventuellement 
changées 

 Retournez dans le menu Manufacture→Create Drill table. 

Une fenêtre s’ouvre qui est la 
mise en forme du tableau à partir 
d’un fichier *.dlt. 

 Cliquez sur OK, le tableau est 
accroché au curseur. 

 Posez-le à droite de la carte. 
Sa taille dépend des éléments qui 
y figurent, la taille de texte est 
définie dans le tableau accessible 
dans clic droit→Quick Utilities→Drawing parameters puis onglet 
Text et bouton Setup Text Sizes. 

 

La création du ou des fichiers de perçage est faite à partir de la 
commande Export→ NC Drill. 

 

 

Création des fichiers Gerber : 
  Allez dans le menu Export→Gerber. 

La fenêtre Artwork Control apparait. 
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 Sélectionnez l’onglet General Parameters puis réglez les options 
suivantes : 

Device Type : Gerber 274X 

Integer Place :3 

Decimal Place :5 

Un message sur la précision de sortie apparaitra pendant la 
configuration.  

 Cliquez sur le bouton OK. 

Le fichier art_param.txt est écrit dans le répertoire. 

 Retournez dans le menu Export→Gerber puis sélectionnez l’onglet 
Film Control. 

 Cliquez sur le signe + à gauche du nom de film BOTTOM. 

Les éléments qui serviront à la création de ce fichier Gerber 
apparaissent. 

 Sélectionnez la coche de ce film. 

 Faites de même pour le film TOP. 

 Si vous souhaitez ajouter des films, il vous suffit de placer le curseur 
sur une des définitions existantes puis d’appeler le menu contextuel 
pour utiliser la commande Add. 

La nouvelle définition, une fois nommée, 
absorbe les règles de l’affichage en cours.  

 

 Si vous souhaitez ajouter des sous-
classes dans une définition de films, utilisez 
la commande Add à partir du menu 
contextuel sur une sous-classe d’un film. 

 

 Cliquez sur le bouton Create Artwork. 

Les fichiers Gerber sont générés dans le 
répertoire en cours d’utilisation. 

 

Vues et travaux d’impression : 
Des vues basées sur la visualisation des sous-
classes peuvent être rappelées rapidement à 
condition que ces vues aient été 
précédemment sauvées. 

Elles seront très pratiques lors d’impressions 
de documents. 
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 Cliquez sur l’icône  . 

 Cliquez dans la fenêtre Global Visibility pour choisir All Visible puis 
cliquez sur le bouton Apply. (ou cochez Enable Auto Apply) 

 Sans sortir de la fenêtre Color and Visibility, allez dans le menu 
Display→View→Color View Save.  

Une fenêtre apparait dans laquelle vous allez entrer le nom de la future 
vue. 

 Cliquez sur le bouton  puis indiquez le chemin, cochez l’option 
Change Directory donnez le nom Vue_Totale (pas d’espaces…) et 
cliquez sur Enregistrer. 

Un fichier vue_totale.color est créé dans le répertoire actuel. 

 Choisissez All Invisible dans la fenêtre Color and Visibility puis ne 
rendez visible que le niveau TOP pour Pin,via et Etch dans le Group 
Stack-Up 

 Dans la fenêtre Color Views, tapez TOP puis cliquez sur Save.  

Un fichier Top.color est crée dans le répertoire actuel. 

Le panneau de contrôle peut servir à passer d’une vue à l’autre avec la 
liste de choix Views. Sauvez votre .brd. 

 

 Ouvrez la carte Demo_finished.brd 
et cliquez sur l’icône 3D. Seul le 
DIP14 a été lié à un modèle Step 
(Menu Setup→Step Mapping).  

Ce viewer 3D comporte des 
fonctionnalités de placement, mesure, 
pliage (Flex-Rigid) et détection de 
collisions. 

 Appuyez sur Maj+Bouton du milieu 
de la souris pour faire pivoter la carte 
en bougeant le curseur.  

 

Créer un symbole d’empreinte  : 

Un symbole d’empreinte s’appelle, dans PCB Editor, un  "package 
symbol"  

Ces symboles sont crées soit manuellement soit avec l’outil Package 
Symbol Wizard pour être éventuellement modifiés par la suite. 

 Allez dans le menu File→New, la fenêtre New Drawing est affichée. 
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 Cliquez sur le bouton Browse pour placer le fichier dans le répertoire 
où se trouvent les fichiers avec lesquels vous travaillez. 

 

 

 

 

 

 

 

 Nommez le futur symbole dip24 puis choisissez le Drawing Type 
Package Symbol (wizard) puis cliquez sur le bouton OK. 

 

 Sélectionnez DIP puis cliquez sur 
Next. 

 

 

 

 

 

 Sélectionnez DIP puis cliquez sur 
Next. 

 

 

 

 

 

 Entrez les paramètres tels que vous les 
voyez sur l’image ci-contre puis cliquez 
sur Next. 

 

 

 

 Faites de même pour cette étape 
puis cliquez sur Next. 
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 Cliquez sur le bouton  de 
chacune des lignes Padstack pour 
aller chercher en premier lieu la pastille 
60c85c35d puis la pastille 60s85c35d 
pour la ligne de la pastille 1 puis 
cliquez sur Next. 

 

 

 

 En cliquant sur le bouton Next de la 
fenêtre précédente, le fichier dip24.dra 
sera sauvé en même temps que le 
fichier dip24.psm. Ce dernier est en 
fait le fichier qui est utilisé lors du 
placement de composants, le fichier 
dip24.dra étant le fichier de dessin. 

Une empreinte peut porter des 
pistes et des vias. 

 

Il est possible de placer la hauteur 
de ce symbole, en utilisant la 
commande du menu 
Setup→Areas→Package 
Height. 

 

Cette information sera exportée 
par la commande du menu 
File→Export→IDF pour pouvoir 
être interprétée dans un logiciel de mécanique 
interprétant le standard IDF ou pour l’affichage 
3D. 

Comme l’indique l’image il est possible de surélever une zone pour 
pouvoir glisser des éléments dont la hauteur maximale ne dépasserait 
pas la hauteur  minimale de cette zone en question. 

 

Ce principe s’applique aussir à des zones de hauteurs sur une carte. 
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Créer une pastille : 

La création de pastilles est réalisable avec l’outil Pad Designer 
accessible par Démarrer→Cadence Release 17.2-2016 →Products 
Utilities→PCB Editor Utilities. 

La fenêtre de l’outil ouverte : 

 Allez dans le menu File→Open; puis allez chercher la pastille 
60s85c35d  dans le répertoire 
C:\Cadence\SPB_17.2\share\pcb\pcb_lib\symbols (bibliothèque fournie 
avec le logiciel).  

 

L’onglet Start permet d'indiquer l'usage et la géométrie et de façon plus 
générale, l’unité à utiliser … . 

Le perçage et ses particularités devront être réglés dans l'onglet Drill. 

Une pastille peut être percée en plusieurs endroits 
(Multiple Drill) mais aussi percée avec un usinage 
oblong. (Drill/Slot Hole). 
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Les onglets Design Layers et Mask LAyers permettent de définir la 
géométrie de la pastille. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Les notions Thermal Relief et Anti-Pad sont utilisées lorsque des 
couches de type Plane et négatives sont utilisées sur une carte. 

La notion Regular Pad définit la pastille sur des couches utilisées 
comme positives. 

Les formes peuvent être multiples mais aussi définies par l’utilisateur 
(Shape dans Geometry). 
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La version de démonstration du logiciel OrCAD PSpice permet 
d’évaluer de manière complète toutes les possibilités offertes par le 
logiciel en simulation analogique, digitale et mixte.  

La version PSpice 17.2 Lite présente les caractéristiques suivantes : 

▶ Une bibliothèque de modèles de simulation très complète (+ de 
30000 composants analogiques/numériques) 

▶ Aucune limitation pour l’éditeur de stimuli. 

▶ Caractérisation d’un composant avec PSpice Model Editor  
limitée à la diode.  

▶ Simulation limitée à 75 équipotentielles, à 20 transistors, à 65 
fonctions logiques.  

▶ 10 lignes de transmission (avec ou sans perte) dont 4 lignes 
couplées. 

Il n’existe aucune limitation concernant les types d’analyses dont la liste 
est donnée ci-après : 

▶ Simulation Analogique et Digitale: 

▶ Analyse en Continu : balayage de 2 paramètres simultanément. 

▶ Calcul du point de repos.  

▶ Analyse en température. 

▶ Analyse fréquentielle. 

▶ Diagramme de Bode : Gain et Phase - Diagramme de Nyquist. 

▶ Temps de propagation de Groupe. 

▶ Analyse du bruit. 

▶ Décomposition en série de Fourier. Calcul du taux de distorsion. 

▶ Calcul de FFT (Fast Fourier Transform). 

▶ Analyse temporelle. 

Utilisation d'OrCAD 

PSpice 
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▶ Tracé d’une famille de courbes en fonction d’un paramètre : 
analyse paramétrique ; analyse de performances. 

▶ Analyse statistique de Monte Carlo : tracé d’histogrammes. 

▶ Analyse de Pire Cas. 

▶ Analyse de Sensibilité. 

 

 

Remarques concernant la simulation digitale : 

Les composants digitaux sont simulés à partir de modèles extrêmement 
fidèles. En effet, non seulement les temps de propagation sont pris en 
compte lors de la simulation, mais également les caractéristiques 
d’entrées/sorties (capacités d’entrée, diodes de clamping, diode zener 
...). 

Seul OrCAD PSpice offre un tel degré de modélisation. 

 

OrCAD Capture CIS Lite 17.2 : 

 Limité à 60 composants ou 75 nets en sauvegarde, mais 
possibilité de visualiser des designs sans limitation.  

 Limité à 1000 composants dans la base de données CIS. 

 Création de composants mais limitée à 100 pins 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ce guide vous présente quelque unes des fonctionnalités de Capture 
CIS. Sachez que vous pouvez également parcourir le didacticiel 
proposé par Cadence en sélectionnant la commande Learning 
Capture dans le menu Help. 



Artedas France - Evaluation OrCAD Lite 17.2 – V2 33 

Configuration Capture / PSpice 

Création d’un projet PSpice  
 Lancez Capture à partir du menu Démarrer→Cadence→Release 
17.2-2016 →OrCAD Capture. 

 Accédez au menu File→New→Project 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Remplissez la boîte de dialogue comme ci-dessus puis cliquez sur 
OK. 

La boite de dialogue Create PSpice Project vous donne le choix entre 
créer un nouveau projet à partir d’un projet existant (plusieurs types de 
projet sont disponibles) ou à partir d’un projet vide. 

 Sélectionnez « Create a blank Project » pour créer un projet vide 
puis cliquez sur OK. 

 

 

 

 

 

 

Capture crée un projet (*.opj) et un fichier schéma (*.dsn) dans votre 
répertoire de travail.  

 

Nom du 
projet 

Type de 
projet 

Répertoire de 
travail 
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 Cliquez dans le gestionnaire de projet afin de l’activer. 

 

 

 

 

 

 

 

 

 

 

 

 

Le fichier schéma (essai.dsn) contient ici deux dossiers : 

▷ SCHEMATIC1, le dossier principal du projet qui contient la 
page schéma (PAGE1) 

▷ Design Cache, la bibliothèque liée au projet, contient tous les 
composants utilisés dans le projet. 

 

Les fichiers utilisés lors de la simulation seront déclarés dans le dossier 
PSpice Resources du projet. 

Le gestionnaire de projets permet d’organiser et de gérer tous les 
fichiers de votre projet (y compris les fichiers hors CAO). Tous ces 
fichiers sont considérés comme une entité unique et indissociable. Les 
concepteurs peuvent ainsi rapidement copier, déplacer, supprimer, 
parcourir ou archiver un projet sans perte de fichiers et de données 
essentielles (définitions de symboles, de modèles, de packages, 
d’empreintes, de stimuli, de configurations Probe...). 

Il permet à l’ingénieur de connaître rapidement la démarche et les 
options de conception mises en œuvre lors de la réalisation du projet. 

Remarques : 

▶ les projets sont enregistrés avec l’extension .OPJ  

▶ le fichier schéma principal avec l’extension .DSN 

▶ les bibliothèques de composants avec l’extension .OLB 

▶ les bibliothèques de modèles avec l’extension .LIB 
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Les fichiers (schéma, bibliothèques) sont déclarés dans le projet ; ils ne 
sont pas inclus dans le fichier projet (*.OPJ). 

Structure créée sur le 
disque : 

 

 

 

 

 

 

 

 

 

La saisie de schémas est l’outil névralgique d’OrCAD PSpice. 

 

C’est en effet depuis la saisie de schémas que pourront être définis : 

▷ les signaux de test à appliquer au circuit 

▷ les types de simulation (fréquentielle, temporelle, statistique) 

▷ les spécifications des nouveaux modèles, ou encore le 
paramétrage des signaux à visualiser dans l’oscilloscope. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Répertoire Fichiers 
PSpice 

Répertoires 
relatifs aux 
dossiers schéma 

Répertoire relatif au profil de 
simulation 
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Placer des composants PSpice sur le schéma : 
 Entrez dans le menu  Place→PSpice Component. 

Vous avez ainsi accès à plusieurs sous-menus pour placer différent 
type de composants : Résistance, Capacité, Inductance, Diode, 
Discrete (Transistors bipolaires, MOS, JFET, IGBT), Digital (Portes 
logiques, ADC, DAC, ROM, RAM) et les Sources. 

 Sélectionnez le menu Diode. La 
diode est attachée au curseur 

 Clic bouton gauche pour placer la 
diode sur la page. 

 Pour quitter le mode insertion de la 
diode, touche Echap ou clic droit et 
End Mode 

 Sélectionnez le menu Seach 

 

Un nouveau panneau s’ouvre à la droite 
du schéma 

L’onglet Catégories classe les 
composants selon leur principale 
fonction. 

L’onglet Library classe les composants 
selon leur librairie. 

Il est possible de rechercher un 
composant selon sa fonction à l’aide de 
cette fenêtre. 

 Editez triac 40 amp puis touche 
Entrée au clavier. 

 Sélectionnez cette icône pour 
prévisualiser le symbole. 

 

 

 Sélectionnez le composant dans le 
panneau puis double-clic bouton 

gauche ou clic bouton droit et choissisez Place Symbol pour accrocher 
le symbole au curseur. 
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 Pour placer le composant sur la page schéma : clic gauche. 

 Pour quitter le mode insertion de composant, touche Echap ou clic 
droit et End Mode. 

 

Ajout de connexions : 
Pour interconnecter les éléments sur le schéma : entrez dans le menu 

Place/ Wire ou touche W ou icône  

 

Masse Analogique :  
Pour réaliser une simulation, il est indispensable de préciser la masse 
du circuit. Celle-ci est accessible via le menu Place→PSpice 
Component→PSpice Ground. 

 

Les Sources :  
Place→PSpice Component→Source→Voltage Sources 

 

DC : Source de tension continue 

 

AC : Source de tension pour les analyses fréquentielles. 

NE CONVIENT PAS POUR LES ANALYSES 
TEMPORELLES 

 

Sine : Source de tension sinusoïdale pour les analyses 
temporelles. 

 

Paramétrage :  

▷ VOFF = Tension d’offset 

▷ VAMPL = Amplitude 

▷ FREQ = Fréquence 

▷ TD = Délai à l’apparition du signal (facultatif ; 0 par défaut) 

▷ DF = Coefficient d’amortissement (facultatif ; 0 par défaut) 

▷ PHASE = Phase (facultatif ; 0 par défaut) 

Ces paramètres sont accessibles en sélectionnant la source et en 
cliquant à droite sur la commande Edit Properties… 
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La figure qui suit représente une simulation de cette source de tension 
dont le coefficient d’amortissement est non nul. 

 

 

Exemple de tension 
générée avec VSIN :  

Courbe réalisée avec DF 
différent de 0 ; la sinusoïde 
est amortie. 

 

 

 

 

 

Exponential : Source de tension exponentielle ; 

 

 

 

 

 

 

 

FM Sine : Source de tension modulée en fréquence. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

            
Frequency 

0.80MHz 0.85MHz 0.90MHz 0.95MHz 1.00MHz 1.05MHz 1.10MHz 1.15MHz 1.20MHz 
V(ENT) 

0V 

0.5V 

1.0V 
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Pulse : Source de tension rectangulaire périodique. 

 

 

 

 

 

 

Paramétrage :  

▷ V1= Tension de repos 

▷ V2 = Tension impulsionnelle 

▷ TD = Temps de retard à l’apparition du signal 

▷ TR = Temps de montée 

▷ TF = Temps de descente 

▷ PW = Largeur d’impulsion 

▷ PER =Période 

 

 Accédez au menu Place→PSpice 
Component→Source→Independent Sources ou au clavier Shift+R. 
Cette fenêtre vous aidera à créer votre source de tension ou de 
courant. 
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Il suffit de sélectionner le type de source que vous souhaitez utiliser, de 
renseigner ces paramètres et de la placer. Si vous souhaitez modifier 
une source placée, sélectionnez la puis Shift+I. 

 Accédez au menu Place→PSpice Component→Source→PWL 
Sources. Cette fenêtre vous aidera à créer votre source de tension ou 
de courant définies à l’aide de couples de points ou associer à un 
fichier. 
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Simulateur OrCAD PSpice 

PSpice et les unités : 

Les éléments passifs - résistances, inductances, condensateurs - ne 
nécessitent pas la spécification de l’unité - Ohm, Henry ou Farad. 

Par ailleurs PSpice reconnaît les notations scientifiques. Mais attention ! 
Il n’existe aucune différence entre majuscules et minuscules, ainsi 
“1M“ne signifie pas 1 Million mais 1 millième ! 

 

109 = 1G, ou 1g 

106 = 1MEG, ou 1meg  

103 = 1K ou 1k 

10-3 = 1M ou 1m 

10-6 = 1U ou 1u (Le caractère "µ" n’est pas reconnu par PSpice) 

10-9 = 1N ou 1n 

10-12 =1p ou 1p 

10-15 =1F ou 1f 

Analyse temporelle et de Fourier  

 Chargez le schéma sous le projet Example.opj avec les 
commandes Files→Open→Project depuis le sous répertoire : 

C:\Cadence\SPB_17.2\Tools\PSpice\Capture_Samples\Anasim\Examp
le\Example.Opj 

 

 

 

 Ouvrez le 
schéma 
PAGE1 à partir 
du gestionnaire 
de projet en 
développant  
Design 
Ressources→
example.dsn→
Example 
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Remarque : des "markers" ont été placés sur les fils nommés OUT1 et 
OUT2. Ce sont des sondes de tensions, placées à l’aide du menu: 

PSpice→Marker→Voltage Level, et dont le rôle est d’afficher 
automatiquement les tensions OUT1 et OUT2 dans PSpice. 

Des "markers" permettent également d’afficher dans PSpice, une 
tension différentielle, un courant, une tension ou un courant en Db, la 
phase d’un signal, la partie réelle ou imaginaire d’un signal. 

 
Paramétrage de la simulation 
En accédant au tableau de contrôle de la simulation (PSpice→Edit 
Simulation Settings), il sera possible de vérifier le paramétrage de la 
simulation : 

L'icône  de la barre d'outils permet également d'accéder à ce menu. 

 

Paramètres de l’analyse temporelle : 
Time Domain (Transient) comme Analysis Type  

 
Run To Time: Durée totale d’analyse. 

Start saving data after : Retarde l’enregistrement des résultats 
(facultatif).  

Maximum Step Size : Pas de calcul maximum (facultatif). Par défaut 
TSTOP/50. 

Skip initial transient bias point calculation (SKIPBP) : le calcul du 
point de repos n’est pas calculé (facultatif). 
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Output File Options… : 

Perform Fourier 
Analysis : Calcul les 9 
premiers termes de la 
série de Fourier ; effectué 
sur le signal V(OUT2) 
dont la fréquence 
fondamentale est de 
5MHz. Résultats édités 
dans le fichier rapport 

(View/Output file). 

Include detailed bias … : Inclut dans le fichier .out les détails sur le 
point de repos des sources et des semi-conducteurs.  

 Fermer la fenêtre de configuration d’analyse : OK. 

 
Résultats de l’analyse temporelle : 
La simulation sera lancée à l’aide de PSpice→Run, ou à l'aide de 

l'icône  de la barre d'outils. 
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PSpice s’exécute et les résultats de simulation V(out1) et V(out2) 
s’affichent automatiquement, en conséquence des markers placés sur 
le schéma. 

Pour visualiser d’autres résultats : 

 Entrez dans le menu Trace→Add Trace et sélectionnez les signaux 
à afficher. 

Remarques : les courbes visualisées sont légèrement segmentées : 
cela est dû au pas de calcul pris par PSpice. 

Pour visualiser les points calculés : 

 Sélectionnez Mark Data Points dans le menu Tools→Options ou 

cliquez sur l'icône . 

Pour obtenir un pas de calcul plus fin : 

 Retournez dans le menu PSpice→Edit Simulation Profil  (sous 
Capture) et éditez 5n dans le champ Maximum Step Size. 

 Fermez la fenêtre de simulation puis relancez la simulation. 

 

Résultats de l’analyse de Fourier : 
 Examinez le fichier rapport de Simulation à l’aide de View→Output 
File : 

Les résultats de l’analyse sont présentés à la fin du fichier Output : 

FOURIER COMPONENTS OF TRANSIENT RESPONSE V(OUT2) 

 DC COMPONENT =   5.581478E+00 

 HARMONIC   FREQUENCY    FOURIER    NORMALIZED    PHASE        
NORMALIZED 

    NO         (HZ)     COMPONENT    COMPONENT    (DEG)       
PHASE (DEG) 

     1     5.000E+06    3.492E-01    1.000E+00   -9.850E+01    0.000E+00 

     2     1.000E+07    8.028E-03    2.299E-02    3.282E+01    2.298E+02 

     3     1.500E+07    2.977E-03    8.527E-03   -1.380E+00    2.941E+02 

     4     2.000E+07    2.256E-03    6.460E-03    1.816E+00    3.958E+02 

     5     2.500E+07    1.795E-03    5.141E-03    3.414E+00    4.959E+02 

     6     3.000E+07    1.463E-03    4.188E-03    3.903E+00    5.949E+02 

     7     3.500E+07    1.270E-03    3.637E-03    1.784E+00    6.913E+02 

     8     4.000E+07    1.137E-03    3.255E-03    3.287E+00    7.913E+02 

     9     4.500E+07    9.509E-04    2.723E-03    4.681E+00    8.912E+02 

     TOTAL HARMONIC DISTORTION =   2.679869E+00 PERCENT 
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PSpice→Edit Simulation Profil  

Probe Window : Contrôle de la configuration pour un affichage 
automatique des résultats après simulation 

 

 

 

 

 

 

 

 

 

Cette option permet d'observer tous les signaux associés aux sondes 
après la simulation. 

Création de versions de projets 

Cette fonction permet aux concepteurs de sauvegarder intégralement 
des versions de leurs projets pour réaliser des analyses comparatives 
et d’optimiser la conception. 

Elle permet de visualiser dans PSpice tous les résultats de simulations 
des différentes versions du projet. 

Exemple :  

 Sous Capture, dans le gestionnaire de projet *.OPJ, placez-vous 
sous la racine  .\example.dsn. 

 Créez un nouveau schéma dans le menu 
Design→New Schematic… et tapez 
Check1. 

 Dans le répertoire Example, copiez 
PAGE1 (Ctrl+C), puis collez-le dans Check1 
(Ctrl+V). Un ‘+’ doit apparaître devant ce 
répertoire, et à l’intérieur la copie de PAGE1. 

 Dans ce schéma, modifiez les valeurs de 
RC1 et RC2 : 15k et 15k en double-cliquez 
sur les valeurs. Ensuite cliquez sur Save et 
fermez la page. 

Sélectionnez Check1 puis Design→Make 
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Root : le fichier Check1 est devenu « principal ».   

 Puis PSpice→New simulation Profile. Dans name, tapez TRAN, 
dans inherit from sélectionnez Example-TRAN et cliquez sur Create. 

 Lancez la simulation à partir du menu PSpice de Capture.  

 Sous PSpice dans le menu File→Append Waveform(.dat)… : 
ouvrez le fichier TRAN.dat. contenu dans le dossier  : 
\Tools\PSpice\capture_samples\anasim\example\Example-PSpiceFiles 
\Example\Tran 

 

 

 

 

 

 

 

 Cliquez sur Do Not Skip Sections 

 Enfin, dans Trace→Add Trace…, sélectionnez les signaux V (out1) 
et V (out2) par un clic bouton gauche. 

 

 
 

 

 

 

 

 

 



Artedas France - Evaluation OrCAD Lite 17.2 – V2 47 

Analyse fréquentielle et de bruit 

La rubrique AC SWEEP dans PSpice→Edit Simulation Profiles 
permet de réaliser une analyse en fonction de la fréquence. 

Elle permettra notamment de tracer un diagramme de Bode ou un 
diagramme de Nyquist. 

 

Attention ! Seules les sources de tension dont l’attribut AC a été 
paramétré seront balayées en fréquence.  

 

Dans le circuit example, la source de tension V1 doit être paramétrée 
pour respecter cette règle. Pour cela : sélectionnez la source V1 puis 
clic bouton droit et choisissez Edit Properties pour accéder aux 
propriétés.  

Sélectionnez le bouton Pivot pour visualiser les propriétes sous forme 
de lignes. 

 

 

 

La valeur de la propriétée AC est ici de 
1V permettant de réaliser une 
simulation fréquentielle. Editez 0.125V 
pour la valeur de la propriété DC pour 
polariser le circuit. 

 

 

 

Remarque : V1 pourrait être remplacée par une source de tension 
VAC. 

 

Analyse fréquentielle : 
 

A partir du dossier PSpice Resources du gestionnaire du projet, 
rendez actif le profil de simulation Example-AC (En sélectionnant le 
profil puis à l’aide du menu contextuel sélectionnez Make Active). 
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Paramétrage de l’analyse AC Sweep :  

▷ Start Freq et End Freq déterminent les bornes de l’étude 
fréquentielle. 

 

Calcul du bruit :  

▷ Output Voltage : Point où sera calculé la valeur efficace du 
bruit total en sortie. 

▷ I/V Source : Point où sera calculé la valeur efficace du bruit 
ramené à l’entrée. 

 
Préparation de l’affichage des résultats : 
 

 Pour visualiser les signaux en décibels, entrez dans le 
menu PSpice→Markers→Advanced→DB Magnitude 
of Voltage  

 

 Placez les marqueurs sur les sorties OUT1 et OUT2 

Simulez : PSpice→Run. 
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Résultats de la simulation fréquentielle : 
 

 

 
Phase des signaux 
 Ajoutez une nouvelle fenêtre de visualisation à l’aide de Plot→Add 
Plot to Window. 

 Puis dans Trace→Add Trace…, sélectionnez l’opérateur P() 
(opérateur de phase). 

 Puis sélectionnez V(out2). 
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Mise en place de curseurs sur les courbes :  
Pour connaître précisément la valeur d’un signal en un point particulier, 
PSpice A/D dispose de 2 curseurs que l’on active à l’aide de la 

commande Trace→Cursor→Display ou sur l'icône . 

 Le premier curseur est attaché sur le bouton droit de la souris, le 
second sur le bouton gauche. 

 Cliquez sur l’icône  pour placer des marqueurs sur la courbe, 

 

PSpice affiche dans une 
fenêtre séparée les 
coordonnées des deux 

curseurs et les différences X 

et Y. 

 
Evaluation du bruit du circuit :  
Dans PSpice, vous avez accès aux bruits de papillotement (NF : flicker 
noise), de grenaille (NS : shot noise), thermique (N) et total (NTOT) de 
chaque composant source de bruit. Ces bruits s’expriment en Volt2/Hz. 

▷ NTOT(ONOISE) bruit total du circuit en sortie :  
NTOT(composant). 

▷ V(ONOISE ) = NTOT(ONOISE) (valeur efficace du bruit total 
de sortie) 

▷ Et V(INOISE) = V(ONOISE)/gain s’exprime en Volt/Hz1/2. 

 

Pour réaliser les courbes illustrées ci-dessous, suivez les étapes :  

1. Menu Plot→Delete Plot 

2. Puis Trace→Delete All Traces 

3. Puis Plot→Add Plot to Window 

4. Dans le graphe supérieur Trace→Add Trace… 
NTOT(ONOISE), NTOT(Q1), … 

5. Dans le graphe inférieur Trace→Add Trace… V(INOISE), 
V(ONOISE). 
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Analyse paramétrique 

Cette section présente la mise en œuvre d’une analyse paramétrique, 
ce qui vous permet de répéter une analyse (temporelle, ou 
fréquentielle…) pour différentes valeurs d’un composant. 

Dans cet exemple, la simulation temporelle sera répétée pour plusieurs 
valeurs de R1. 

 Créez un nouveau projet depuis le menu File→New→Project, 
appelez-le ‘PARAM’ puis choisissez Analog or Mixed…, et saisissez 
le schéma ci-dessous : 

  

RAPPEL : Le symbole de la masse (Menu Place→PSpice 
Component→PSpice Ground) 

Ne pas oublier de nommer l’équipotentielle VS (Place→Net Alias). 
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 Shift+R au clavier ou menu Place→PSpice 
Component→Source→Independent Sources pour créer et placer la 
source V1. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Principe du paramétrage : 

 Remplacez la valeur de la résistance par un nom de variable entre 
accolade comme : {RVAR}. 

 Placez sur le schéma l’élément PARAM avec le menu Place→ 
PSpice Component→Search, onglet Library et sélectionnez la 
librairie Special. 

Pour déclarer ce paramètre dans PSpice : 

 Editez les propriétés Edit→Properties puis cliquez sur New 
Property 

 Editez RVAR dans le champ Name, 50 dans le champ Value, 
cochez Display [ON/OFF] puis OK 

  

 

 

 

 

 

 

 

 Sélectionnez Name and Value dans la fenêtre suivante puis OK 
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 Dans PSpice→New Simulation Profile, donnez un nom puis 
cliquez sur Create. 

 Accédez à l’option Parametric pour spécifier les valeurs du 
paramètre RVAR. 

 
Toujours dans la même fenêtre :  

 Sélectionnez General Setting, éditez 3ms dans le champ Run to 
Time et 10us pour Maximum Step Size. 

 Fermez la fenêtre de simulation : OK. 

 Lancer la simulation : A la fin de la simulation PSpice affiche la liste 
des simulations calculées, sélectionnez All, appuyez sur OK, une 
famille de courbes s’affiche (Ne pas oublier le marqueur de tension sur 
votre schéma (Menu PSpice→Markers→Voltage Level). 

 
Si vous sélectionnez une courbe puis clic bouton droit et choisissez 
Trace Information dans le menu contextuel, une fenêtre s’affiche alors 
indiquant la valeur du paramètre associée à cette courbe. 
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Analyse de Performances 

Par ailleurs il est possible de réaliser une analyse de performance du 
circuit, en fonction d’un paramètre - ici RVAR. Dans cet exemple nous 
étudierons le temps de montée de 10% à 90% de la valeur finale du 
signal V (VS) en fonction de RVAR. 

 
Pour cela, entrez dans le Menu Plot→Axis Settings…/X Axis et 
sélectionnez l’option Performance Analysis ou sélectionnez l'icône 

. Cette action à pour effet de placer le paramètre RVAR sur l’axe X 
dans un nouveau graphe. De plus, le menu Trace→Add propose 
maintenant un certain nombre de Measurements. 

Ces Measurement functions prédéfinies dans le fichier ASCII 
PSPICE.PRB (C:\Cadence\SPB_17.2\Tools\PSpice\Common), 
permettent de mesurer une caractéristique particulière sur une famille 
de courbes. 

Voici la signification de quelques-unes unes d’entre elles : 

▷ BandWidth: Bande passante d’un filtre. 

▷ CenterFreq: Fréquence centrale d’un filtre passe bande. 

▷ OverShoot: Dépassement 

▷ Risetime_NoOvershoot : 
Temps de montée de 10 à 90% de la valeur finale (signaux 
sans dépassement). 

▷ Risetime_StepResponse: Temps de montée pour un signal 
avec Overshoot. 

Dans l’exemple, accédez au menu Trace→Add Trace et sélectionnez 
Risetime_StepResponse (V(VS)) pour avoir un temps de montée de 
10% à 90% de la valeur finale d’un signal avec Overshoot. 

 Sauvegardez et fermez votre projet. 

Le fichier PSPICE.PRB est documenté : imprimer le pour plus 
d'informations. 
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Simulation analogique et digitale : 

 Chargez le schéma PAGE1 dans le projet OSC.OPJ situé dans le 
sous répertoire : 
......\Tools\PSpice\Capture_Samples\Mixsim\Osc\Osc.opj 

 

Double-cliquez sur PAGE1 dans la racine OSC de Design 

Resources. 

 

 Puis lancez la simulation à l’aide de PSpice→Run  ou   
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Commentaires sur la simulation Mixte 

Alimentations 
Les alimentations des composants numériques n’apparaissent pas sur 
le schéma et leur définition est optionnelle. 

Par défaut les éléments CMOS et TTL sont alimentés en 5V.  

Construction du schéma 
La construction d’un schéma mixte s’effectue exactement de la même 
manière qu’un schéma analogique, et ne nécessite aucun paramétrage 
particulier. 

Affichage des résultats 
L’affichage des signaux numériques et analogiques s’effectue 
simultanément dans PSpice. Tous les signaux appartenant à une 
équipotentielle en liaison directe avec un élément purement analogique 
(Résistance, Transistor, Condensateur...), sont traités comme des 
signaux analogiques. Ceux qui ne sont pas en contact avec des 
éléments analogiques, en l’occurrence RESET et OUT, sont considérés 
comme digitaux. 

Remarque : pour transformer OUT en un signal analogique il suffit de 
placer une résistance entre la sortie de la bascule JK et la masse. 

 

Par ailleurs en effectuant un zoom sur les transitions du signal OUT, on 
constatera la modélisation et la représentation par PSpice des états R 
(Rise) et F (Fall) qui sont définis comme étant des phases de passage 
de l’état logique ‘0’ vers ‘1’ et inversement - phases durant lesquelles le 
signal est dans une plage d’indétermination. 

 

 

 

 

Etat Fall  
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La version de démonstration du logiciel OrCAD PSpice Advanced 
Analysis (PAA) permet de découvrir les analyses qui vous aident à 
optimiser les performances et les qualités de vos circuits. 

▶ Analyse de Sensibilité 

▶ Optimisation 

▶ Analyse de Monte-Carlo 

▶ Analyse de Stress 

▶ Analyse Multi-Paramètres. 

 

La version d’évaluation présente des limitations : 

▶ Analyse de Sensibilité : étude d’une spécification sur 3 
composants, limitée à 20 simulations. 

▶ Optimisation : Optimise 2 valeurs de composants pour un seul 
but. Moteurs de recherche : Random (limité à 5 runs) ou LSQ 
modifié. 

▶ Analyse de Monte-Carlo : 1 spécification pour 3 composants sur 
20 runs. 

▶ Analyse de Stress : limitée aux diodes, transistors, résistances 
et capacités. 

▶ Analyse Multi-Paramètres : 2 paramètres, en variation linéaire, 
sur 10 valeurs. 

 

Pour suivre la démo, copiez le dossier RFAMP contenu dans le fichier 
exemple (http://www.artedas.com/FR/OrCAD/OrCAD_Lite.php) dans 
C:\Cadence\SPB_17.2\Tools\PSpice\Demo_Samples  

Pspice Advanced 

Analysys 

http://www.artedas.com/FR/OrCAD/OrCAD_Lite.php
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Load

.47u
C7

D1

1N4148

0

0

In

+VCC

RF Amplifier

V1
15VDC

0 0

In+VCC

50

R5

V2

AC = 1

TRAN = Sin(0 5m 1Meg)

DC = 0

.47u

C6

0.01u
C1

.47u

C3

Q3

Q2N5179 50
R9

470
R6

3.3
R8

3k
R2

Q4

Q2N3905

470
R4

270
R7

6.8k
R3

24k
R1

Q2E

Tolerances Smoke Limits

User Variables

DSMAX = 300

RMAX = 0.25

LTOL = 0

LMAX = 5

ITOL = 0

CIMAX = 1

IMAX = 1

RTMAX = 300

CTOL = 10
RSMAX = 0.005

CTMAX = 125

RTOL = 10

CMAX = 50
CBMAX = 125
CSMAX = 0.005

VTOL = 0 VMAX = 12

10u
C4

Q1E

Analyse de sensibilité 

 Chargez le projet RFAMP.OPJ situé dans le répertoire 
C:\Cadence\SPB_17.2\Tools\PSpice\Demo_Samples\RFAMP 

 Ouvrez la page schéma. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Sur le schéma, le composant VARIABLE (librairie Special.olb) est utilisé 
pour définir globalement les tolérances des composants (Ex : CTOL est 
la tolérance des capacités, ici elle est de 10%) et la valeur des 
caractéristiques des composants utilisées pour l’analyse de « smoke » 
(Ex : RMAX est la valeur limite de la puissance dissipée pour les 
résistances, ici 0.25 Watt). 

  Double-cliquez sur la résistance R4. 

Toutes les propriétés pour PAA 
sont accessibles (POWER : 
puissance maximale) 

La propriété TOL_ON_OFF 
permet de prendre en compte le 
composant lors de l’analyse de 
sensibilité. 

 Passez la valeur à ON. 

 Faîtes de même pour les 
résistances R4, R6 et R8. 

 Activez le profil de l’analyse 
AC et simulez le circuit. 
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Dans PSpice, les fonctions « Measurements » nous indiquent un gain 
maximal de 9.48 et une bande passante à 3 dB de 172 Meg. 

 Depuis Capture, accédez au menu PSpice/Advanced 
Analysis/Sensitivity 

 Dans le panneau Specifications, cliquez sur « Click here to … » 

 Sélectionnez la fonction Max(db(v(load))) 

 Menu Run/Start Sensitivity 

 Dans le menu Analysis/Sensitivity/Display, validez Relative 
Sensitivity et Value 

 
La résistance R4 est la plus sensible : une variation de 1% de sa valeur 
augmente le gain de 37.3103 mdB.  

La valeur maximale du gain (10.32 db) est atteinte lorsque la résistance 
R4 vaut 517, R8 vaut 2.97 et R6 vaut 423. Ces valeurs prennent en 
compte les tolérances définies sur les composants (ici 10%). L’analyse 
de sensibilité nous indique de ce fait les pire-cas. 

Vous pouvez supprimer la spécification (sélectionnez la ligne, clic BD 
de la souris et Delete) et choisir la bande passante à 3dB. 

 
R6 est ici la plus sensible : la bande passante augmente de 734k  
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Les composants sensibles ou critiques peuvent ensuite être optimisés 
pour améliorer ou modifier les caractéristiques du circuit. 

 Dans le panneau des Parameters, sélectionnez la ligne 
correspondante à la résistance R6, clic BD de la souris puis Send to 
Optimizer. 

 Faîtes de même pour la résistance R4. 

 Menu View→Optimizer. 

Optimisation 

 Dans le panneau Specifications, cliquez sur « Click here to … » 

 Sélectionnez la fonction bandwidth(v(load),3) 

 Sélectionnez le moteur de recherche « Modified LSQ »  

 

 

 

 

 

Celui-ci est basé sur la méthode des moindres carrés mais avec prise 
en compte de contraintes. Il essaye d’atteindre les buts fixés tout en 
respectant les contraintes. 

Le moteur « Random » quadrille l’espace de variation des paramètres 
et tire de façon aléatoire des points de cette grille ; en final, le meilleur 
« run » est répété pour une optimisation plus fine de type LSQ. 

 Dans le panneau Specifications, specifies 200meg dans les 
colonnes Min et Max. C’est le but à atteindre : une bande passante de 
200Meg 

 Pour lancer l’optimisation: Menu Run→Start Optimizer 
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Les valeurs optimisées pour les composants R6 et R4 sont éditées 
dans la colonne « Current ». 

Ces valeurs permettent d’obtenir une bande de 200.46 Meg. 

 Sélectionnez les valeurs courantes, clic BD de la souris puis Delete 

 Sélectionnez la spécification bandwidth(v(load),3), clic BD de la 
souris puis Delete. 

 Prenez le gain « (max(db(v(load))) » comme spécification et lancez 
une optimisation pour obtenir une valeur de 7dB. 

Les valeurs optimisées pour les composants R6 et R4 sont alors 
différentes. 

Les colonnes Min et Max du panneau « Parameters » permettent de 
définir les bornes de variations des valeurs. 

 Menu View→Monte Carlo. 

Analyse de Monte-Carlo 

 Dans le panneau Statistical Information, cliquez sur "Click here to 
… ". 

 Sélectionnez la fonction bandwidth(v(load),3) 

 Pour lancer l’analyse : Menu Run→Start Monte Carlo 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Positionnez le curseur Min à 1.68e8 et le Max à 1.8e8 ceci permet 
de définir la marge que vous souhaitez sur la bande passante. 

Dans la colonne Yield, le rendement est de 75%. Pour l’augmenter, il 
faudra diminuer les tolérances. 
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 Menu View/Log File/Monte Carlo pour éditer le rapport spécifiant 
les valeurs appliquées aux composants ainsi que les valeurs de la 
spécification pour chaque run. 

 Onglet « Raw Meas » du panneau Statistical Information permet 
également d’afficher les valeurs de la spécification pour chaque run. 

 Menu Edit→Profile settings pour configurer l’analyse (nombre de 
runs par exemple) 

 Menu View→Parametric Plot. 

Analyse Multi-paramètres 

 Dans le panneau "Sweep Parameters", cliquez sur "Click here to 
… ". 

 Cliquez sur la case Sweep Type relative au composant R8 et 
validez Linear 

 Cliquez sur la case Sweep Values relative au composant R8 et 
remplissez le panneau comme ci-dessous. 

 

 

 

 

 

 

 

 

 

 

 Faîtes de même pour le composant R6 avec Start Value=450, End 
Value=470 et Step Value=20 

 Puis OK pour quitter la fenêtre Select Sweep Parameters. 

 Dans le panneau « Measurements », cliquez sur « Click here to 
… » 

 Sélectionnez la fonction bandwidth(v(load),3) 

 Pour lancer l’analyse : Menu Run→Start Parametric Plot 

Les résultats pour les différentes valeurs des paramètres sont édités 
dans le panneau intitulé Results. 

 Pour afficher les résultats dans PSpice, sélectionnez l’onglet Plot 
Information 
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 Dans le panneau « Plot Information », cliquez sur « Click here to 
… » 

Un assistant vous aide à sélectionner l’analyse, le paramètre à placer 
sur l’axe des X, la grandeur à étudier (sur l’axe Y) en fonction d’un 
second paramètre. 

Le paramètre sur l’axe des X est la résistance R8, sur l’axe Y la fonction 
mesure bandwidth(v(load),3) et le paramètre est la résistance R6. 

 

 

 

 

 

 

 

 Sélectionnez la ligne du Plot1, clic BD de la souris puis Display Plot 

 

 

 Dans PSpice Advanced Analysis, menu View→Smoke. 
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Analyse « Smoke » 

Cette analyse utilise les résultats d’une simulation temporelle. 

 Dans Capture, activez le profil de l’analyse tran et simulez le circuit. 

 Dans PSpice Advanced Analysis, menu Run→Start Smoke 

 Dans le panneau des résultats, cliquez sur BD de la souris et 
sélectionnez Hide Invalid Values et Parameters Description 

Ici la température de R6 est la caractéristique la plus proche de sa limite 
(20%). Mais la marge reste importante. 

Par défaut, aucune dégradation n’a été définie : en fait 100% de la 
valeur limite. 

Il est possible d’appliquer une dégradation globale sur une 
caractéristique ou spécifique à un composant. 

 Dans PSpice, éditez le profil de simulation, validez une analyse en 
température à 100°C et simulez. 

 
 Dans PSpice Advanced Analysis, menu Run→Start Smoke 
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 Dans le panneau des résultats, cliquez sur BD de la souris et 
sélectionnez Component Filter, éditez R6 et OK. 

Sa température passe à 132°C et conduit à une dégradation de la 
puissance maximale : la limite tombe à 209 mW. 

 Dans Capture, passez le paramètre CMAX du composant 
VARIABLE à 10. Celui-ci représente la tension maximale aux bornes 
des capacités. 

 Simulez et relancez une analyse Smoke. 

 Dans le panneau des résultats, cliquez sur BD de la souris et 
sélectionnez Component Filter, éditez C* et OK. 

 

 

Lorsque la valeur d’un paramètre dépasse sa valeur limite, la ligne 
relative passe au rouge : le circuit n’est plus fiable. 
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C’EST AUSSI DES FORMATIONS
Toute l’année, des sessions vous sont proposées pour concevoir et simuler  
les projets analogiques/mixtes complexes, router les circuits imprimés dans  
des conditions optimales, exploiter les performances du langage VHDL dans  
la conception des FPGAs et des circuits programmables. En complément  
des sessions traditionnelles, Artedas organise des formations spécifiques,  
sur site et personnalisées, en fonction des projets à traiter (plus de 2800 
ingénieurs et techniciens déjà formés). Les sessions sont dispensées par  
des formateurs expérimentés. Filières, sessions, planning, infos pratiques 
et préinscription sont disponibles sur : www.artedas.fr (rubrique Formation).




